ARpiCADE 4.3 (for RPi4)

Latest on ARpiCADE new releases, release notes, and history of previous versions.

Moderator: dee2eR

dee2eR
Inventor
Inventor
Posts: 1860
Joined: Tue Aug 22, 2017 2:07 pm

Re: ARpiCADE 4.3 (for RPi4)

Post by dee2eR » Sat Aug 13, 2022 7:21 am

how are you launching it in run.sh? With or without using the launcher script? It should work fine to boot to any game before the menu loads with the same results as launching from the menu.

I'll have to experiment with samples in 172, I think you can specify to optionly use samples. If I get any where with it I'll add a way to use samples for particular roms to the 172 launcher.

EDIT: doesn't work right booting at 480i but does at 240p... I'll have to look into that further

kylecities
Community Member
Community Member
Posts: 3
Joined: Tue Aug 30, 2022 6:51 pm

Re: ARpiCADE 4.3 (for RPi4)

Post by kylecities » Tue Aug 30, 2022 9:53 pm

Hi all, I'm new here (hello!) and new to the RaspberryJamma/ARpiCADE, which I've been playing around with since last night.

Pi 4, 4.3.1.

A couple questions so far:

1) I'm running a horizontal monitor, but playing a lot of vertical shmups. Final Burn automatically works perfectly. However, in MAME, it is stretching them to the width of the screen (oof). I've gone into the menu using right + start, but there is nothing in there to unstretch the game. If I flip it sideways, it looks perfect, but again, my monitor is horizontal. Any way to fix this for MAME? (These games are in like Mame 0.215 or something, if that matters)

2) Where do I go to overclock my Pi 4?

3) Is there any way to manually update retroarch cores? It would be nice to update FBN to the newest version, but I don't know if that is possible.

Thank you!

dee2eR
Inventor
Inventor
Posts: 1860
Joined: Tue Aug 22, 2017 2:07 pm

Re: ARpiCADE 4.3 (for RPi4)

Post by dee2eR » Sat Sep 03, 2022 7:02 am

The actual MAME version will make a difference. If you're using 215 I'd try 172, 203 or 230 as 215 is a retroarch core and you'l get better results using vanilla MAME (usually).

OC can be set in config.txt. There's no auto settings for it in the service menu or anything like that.

You can update the cores by manually replacing them with newer ones but I don't recommend it unless there's a good reason to as it can break things in the config files and launcher when features are added or removed. The retroarch cores can be found in /home/pi/.config/retroarch/cores/ (from memory, if that's not the right folder it will be obvious once you look in the retroarch folder). Cores from RetroPie and similar usually work OK on ARpiCADE assuming there's no config file etc. problems.

Tapper
Contributing Member
Contributing Member
Posts: 45
Joined: Sun Mar 17, 2019 9:00 pm

Re: ARpiCADE 4.3 (for RPi4)

Post by Tapper » Thu Oct 20, 2022 7:40 pm

Hey all. I haven't been around in a long time. I have a pi r3b+ and using the last arpicade version for it.

I only run MAME games on a vertical cabinet, including some horizontal games rotated (works pretty well).

Is it worth updating to a pi 4 for me? Will it help make some games run smoother and/or be able to use newer MAME versions with more bugs fixed etc.?

Also, how much RAM is needed?

EDIT: OMG, just saw the prices for pi 4's now?! WTF?! :o

dee2eR
Inventor
Inventor
Posts: 1860
Joined: Tue Aug 22, 2017 2:07 pm

Re: ARpiCADE 4.3 (for RPi4)

Post by dee2eR » Fri Oct 21, 2022 5:17 am

Yeah, at the moment all RPis seem to mainly be available from scalpers... I've seen Pi3s for $300(!), no idea if they're selling at those prices though...

I haven't found any advantage (for what we're using the Pi for) in having more RAM (yet), I don't think the 1gig is still being made so you're probably fine with any model Pi4.

Most of what you'd have in AdvMAME or MAME 078 on Pi3 will run great in MAME 172 (or newer) on Pi4, which is a decent improvement. There's also 8 (I think) vertical NAOMI games you could add using Pi4, some nice SHMUPs on NAOMI so if that's a genre you enjoy it may be worth it just for them.

All that said, the ARpiCADE software isn't as mature on Pi4 and this year new Pi4s were updated silently (possibly just firmware but I'm not sure yet) which has also caused issues. You could wait for the Pi manufacturing/supply to come back to normal, supposedly early next year, to avoid the scalper prices. Hopefully soon enough I'll have the software on Pi4 closer to what I'd like it to be.

Cjoli
Contributing Member
Contributing Member
Posts: 49
Joined: Thu Jan 10, 2019 8:03 pm

Re: ARpiCADE 4.3 (for RPi4)

Post by Cjoli » Sat Nov 12, 2022 3:52 pm

Cjoli wrote:
Tue Jun 08, 2021 6:19 pm
Question on booting to a game, I had my previous Pi3 version boot directly in to Streetfighter 2 as that is the cab I have it in, set this new version to do the same but when it boots to the game its shrunk to about 1/4 the screen in the bottom left. If I exit and then go back into the game its fine?
Just wanted to check in here it's been a while since my last post, for the most part my system has been running fine but wanted to see if there was ever a solution to fix the boot up game?

dee2eR
Inventor
Inventor
Posts: 1860
Joined: Tue Aug 22, 2017 2:07 pm

Re: ARpiCADE 4.3 (for RPi4)

Post by dee2eR » Mon Dec 05, 2022 5:35 am

@Cjoli
Sorry, I haven't figured out why booting to a game starting from 480i isn't working. For whatever reason the res switching seems to like Attract-Mode and is failing prior to Attract-Mode launching... but that's as far as I've gotten on it. The only way I've had boot to a game working was booting in 240p (or 480p due to no res switching).

########

on another note... I've just updated the first post with a zipfile that can get 4.3 running on the new 2022 Pi4s (with the exception of 480i). For those people with new Pi4s stuck with 4.4 pre-alpha it's probably worth using 4.3 instead now.

jehuie
Community Member
Community Member
Posts: 12
Joined: Fri Dec 09, 2022 1:14 am

Re: ARpiCADE 4.3 (for RPi4)

Post by jehuie » Mon Dec 26, 2022 1:24 am

Hi, thank you for the update. I'm a little confused. Probably because I'm new to all this.

I just got a pi4 recently and would like to install the latest working version. Your notes up top seem to say that I need to have Arpicade 4.3 loaded already in order to install 4.31, is this correct? But the link to the version that I see there is 4.3.7....Maybe I need to eat something and then re-read that entire post....

Thank you again!

John

dee2eR
Inventor
Inventor
Posts: 1860
Joined: Tue Aug 22, 2017 2:07 pm

Re: ARpiCADE 4.3 (for RPi4)

Post by dee2eR » Tue Dec 27, 2022 4:04 am

the file type is .7z which I think is confusing you there...

User avatar
cool_factor
Legendary Contributor
Legendary Contributor
Posts: 332
Joined: Tue Sep 26, 2017 10:55 am
Location: Fort Worth TX

Re: ARpiCADE 4.3 (for RPi4)

Post by cool_factor » Fri Jan 06, 2023 2:00 am

Never did this in 3.x not sure what problem is its a sega/play station img that works great in 3.x but has curling and loading issues with 4.3.1 please help. https://youtu.be/2_0kVVxj5Pg

Post Reply