No power on RPI2 (No LED), has to powered up using USB cable

Questions about the RaspberryJAMMA adapter.

Moderator: dee2eR

Post Reply
modology
Community Member
Community Member
Posts: 7
Joined: Tue Jul 30, 2019 2:59 am

No power on RPI2 (No LED), has to powered up using USB cable

Post by modology » Tue Jul 30, 2019 3:18 am

I just got the board today from a seller.

Upon hooking up to my candy cab, I see no power coming to the Pi at all (no LED light comes up).

Then I hook it up to my supergun to test, the supergun is hooked up to psu which is set at 5v. Upon hooked up, i can still no lights come up from the RPI.

But when I hook up the USB cable to power the RPI, the pi indeed turns on and works normally. I can see everything on my crt, can play games, video and sounds are ok as well.

Is it normal that you need to power up the RPI using external USB power adapter? I've thought that the RPI will received the power from the jamma edge of the RaspberryJamma?

https://www.youtube.com/watch?v=HQVRaDO ... e=youtu.be

dee2eR
Inventor
Inventor
Posts: 846
Joined: Tue Aug 22, 2017 2:07 pm

Re: No power on RPI2 (No LED), has to powered up using USB cable

Post by dee2eR » Tue Jul 30, 2019 11:22 pm

It certainly should be powered from the JAMMA edge. If there's no track damage on the RaspberryJAMMA PCB and no issue with the Pi the problem will be either the fuse on the RJ board or the Ribbon cable connecting the PI and RJ.

If you're a computer building/tinkering type you may have a 40 pin cable lying around you could try in place of the short ribbon cable.

modology
Community Member
Community Member
Posts: 7
Joined: Tue Jul 30, 2019 2:59 am

Re: No power on RPI2 (No LED), has to powered up using USB cable

Post by modology » Thu Aug 01, 2019 3:00 am

I dont have spare 40 pin ribbon cable thus I use dupoint cable to connect to each pin accordingly
Upon testing ---> still no LED light ---> RPI not powered up

I also tried to use my spare RPI3 and use the same ribbon cable ----> no power as welll

So pretty much sure that Ribbon cable is not faulty



Perhaps it can be a fuse issue
Still not sure how to do a proper test to know if the fuse is ok or not.
And if it needs to be replaced, what do you call this fuse component so that I can look up online to get new one?

dee2eR
Inventor
Inventor
Posts: 846
Joined: Tue Aug 22, 2017 2:07 pm

Re: No power on RPI2 (No LED), has to powered up using USB cable

Post by dee2eR » Thu Aug 01, 2019 3:42 am

A continuity test across the fuse should let you know if it's any good. If you do need a replacement they're an axial quick blow 2A fuse (ignore the 1A printed on the PCB, I've been using 2A for the last year or so). I would ordinarily link to the part I use on E14s website but it's down for maintenance at the moment.

modology
Community Member
Community Member
Posts: 7
Joined: Tue Jul 30, 2019 2:59 am

Re: No power on RPI2 (No LED), has to powered up using USB cable

Post by modology » Thu Aug 01, 2019 3:47 am

I am not very tech savy but I have this volt meter that have the mode that will beep (if you have touch two of those probes together). I just put each probe at each leg of the fuse, no beep sound. I guess it's dead.
For the replacement part, I gotta travel down to jaycar to see if they have axial quickblow fuse 2A.

Post Reply