Page 1 of 1

Roms not loading, cant find newly added roms - Solved

Posted: Mon Feb 03, 2020 10:15 am
by ant
Hi all

New to the ArPiCade scene, hoping to see if I could get some help from the community.

I recently obtained a 2nd hand Pi jamma setup, not really having much background on them before. Looks to be an older pcb as it does not have dipswitches. Also has a Pi2 board mounted to it.
Owner claimed originally purchased from dee2er (apologies if my names for the equipment are wrong)

It came preloaded with software and a couple hundred roms, which I am unable to determine exact version, but I can tell its an older revision (has 'roms' folder instead of 'arcaderoms' seen in later 3.9, says MAME on splash screen/looks a little old in visuals)

It boots up into vertical orientation and the main game selection screen. Games work. Great.

First thing I done was make an image backup.

Taking a look, the roms are all the older classics (Pacman, Galaga etc etc), and stored in Roms\mame-106
Other emulator folders have no roms at all (fba mame4all mame-078)

Edit: Galaga Fast Shoot was added by using the website link I posted in the below replies. Had to make up a zip file with particular files, add into 106 folder. Working now

Query 2

Edit: Adding into the mame 172 folder fixed CPS 2 games and allows them to boot in now..
I could never get the 078 games (mk1 2 3, nba jam) to function on the pi2/v2 board for some reason. Doing the exact same process on my new v3/pi3b+ board works perfect.
Maybe incompatibility.
Doesnt matter ultimately, as this v2/pi2 board is now being used for my brothers vertical games cab.

Other queries:

for kick buttons - If i were to get the latest setup from dee2er directly, it appears you can dipswitch it to run 6 buttons at the jamma edge like a pandoras box, rather than using the kick harness header, is that correct?
Older board only used kick header right?

Also is there a manual way to map buttons for a specific game if need be, or to change how to exit games back to main menu, or change a games settings in say test menu for cps2 difficulty etc?
Edit: Easy enough to do in everything but FBA ive found. Using TAB key to enter button mapping. Using TEST button on the cab or F2 on keyboard to get into game settings etc.

Also on boot how is it determined to remain in horizontal or vertical orientation?

Ive been trying to navigate between aussie arcade and this pages software and hardware guide area, forum, to try determine which guides, game list compatibility etc are up to date, software download links etc, but was a bit lost in it all, so hoping I've done the right thing thus far.

Thanks guys

Re: Roms not loading, cant find newly added roms

Posted: Mon Feb 03, 2020 1:02 pm
by ant
Galaga Fast Shoot - ... c=151912.0
Made this up and put into 106 folder

Re: Roms not loading, cant find newly added roms

Posted: Mon Feb 03, 2020 10:36 pm
by dee2eR
For query 1: I'm betting the romscan has been disabled due to you getting the SD card with roms pre-installed. Not knowing the version of ARpiCADE it is also makes suggesting what to do a little tricky, but with that said; generally if you want the romscan to run at each boot it is done in the file /boot/ (if you're on an old enough version the file won't exist though).

You can also run a one off romscan from the service menu ('service' or 'f4' from the game select menu, assuming again that your build isn't too old), after doing a scan from the service menu just select reboot to get back to the rom menu.

Q2: I'm not sure but it's probably a rom issue. Do you have the bios file in with the roms? Are you certain they're the right roms for 172?

For 0.78 again I have to assume it's a rom issue, they should work. There should be some datfiles included in the USER_GUIDE folder (all depending on the ARpiCADE version I guess) that you can use with Romcenter or other rom manager software to audit your roms - at least then you can be sure they're not the cause of the issue.

Unlabeled questions....
the RaspberyJAMMA v3 dipswitch functionality is to switch between regular JAMMA (with or without kick harness) and 6 buttons on JAMMA. This can also be done with the earlier board revisions but by linking solder pads on the bottom of the boards, far less convenient than dipswitches.

Button mapping can be changed for just one game (or for all if you want). The process can vary a little between different emulators but for MAME it should be possible using the MAME menus (start+right or tab).

Test menus can usually be accessed, not all MAME versions have the test button configurable (some will, cab test button may already work for some stuff), usually you can use the dipswitch settings in the MAME menus to activate the test menu for a game as well.

You can swap between horizontal and vertical setups from the ARpiCADE service menu (press service or f4 for the game selection menu).

Re: Roms not loading, cant find newly added roms

Posted: Tue Feb 04, 2020 1:37 am
by ant
Mate u were right. fixed it
A little choppy but im gonna look to move to a v3 and pi3 from you anyway. Wondering if itll emulate better in fba Just waiting on my bros vertical cab chassis to be fixed, make sure hes happy to buy the pi2 setup from me first then im free to get a newer setup

Ill have to look into what im missing for mortal kombat nba jam etc next. as suggested

Is there a way to change or disable exiting games. E.g. holding start + button 2 is exiting game at moment. Id like to change to say start+coin for example. Would like to disable everything else except game exit option. Ive already come into a case where a menu came up when doing an in game character code involving start button

Would also love to know exactly what to solder to make 6 buttons at jamma edge. Any guide somewhere or any instruction appreciated for one without dipswitch
I have a jnx adapter previously used for pandora


Re: Roms not loading, cant find newly added roms

Posted: Tue Feb 04, 2020 7:42 am
by dee2eR
On a Pi2 CPS2 should be fine in AdvMAME or FBA, I think - it's been a while since I used a Pi2 beyond seeing if it boots and a quick test.

You should be able to change the hotkeys in hotkeys.ini, although I don't think I set it up to be able to use the coin input (first request for it) as part of the combo. I recommend using the current setting of long holding P1 start to exit but increasing the time it needs to be held if you find it happens accidentally. Not sure about how your older build is setup so it's possible there's been some changes since, hopefully this advice is still relevant. You could always update to the current version of ARpiCADE if you hit issues, although there maybe some boot text visible on Pi2.

You can delete any hotkeys you don't want from the file to have it setup with just an exit hotkey. You can delete the exit command as well if you like but it makes the board a single game unless you have a keyboard plugged in too.

I'll make a guide to set it up for 6 on JAMMA tomorrow, for some reason that one isn't online anymore. Basically you will just need to solder some pads to each other. Can you post a photo of the bottom of the JAMMA board for me? I will then know how it is setup now to give you better instructions in case it's already got some pads soldered.

Also, at the risk of costing myself an eventual sale, you can also upgrade your current v2 RaspberryJAMMA board to a Pi3 if you like. Not sure if you know, the version number isn't related to the Pi version. The V3 RaspberryJAMMA is not that different to the v2, v3 has a video amp and the convenient JAMMA/6-on-JAMMA dipswitches, otherwise they're very similar. Pi3 is a good upgrade from Pi2 though, particularly the Pi3B+.

Re: Roms not loading, cant find newly added roms

Posted: Wed Feb 05, 2020 7:31 am
by ant
Thanks @dee2er

No risk of selling yourself short :) but appreciate the info.
Ultimately we are going to need 2 setups between the two of us.

My brother plays less demanding games and has a vertical cab, so we've decided the 2nd hand pi2 setup will be for him to buy from me / to use.
Just waiting to get word from Jomac for his machines chassis, just to make sure his machine will actually be working and functional again before he commits to the pi2 :)

Once the cabs running (hopefully in the next week), we will setup the pi2 in his cab and make sure hes all happy.
After hes sorted ill focus on myself and ill PM you to organise purchase of your latest setup

So Ive just started setting this pi2 up for vertical and have added games.
So far its looking very promising and games seem to be working great.

So his cab was originally a 2p 6 button horizontal cab. We physically rotated the tube whilst the chassis was sent out for repair.
The cab is currently hard wired to JAMMA edge for pandoras box, with 6 buttons at jamma edge.

Whilst I cant think of any vertical games which would need more than say 3 buttons, still wouldnt mind having it wired as 6 buttons at the edge, in case it does go back to horizontal in future.

Heres a pic of the older pcb we have.
What would need soldering as it doesnt have dip switches?
I was trying to read old posts, but i could only find mention of buttons 4 and 5 at the edge on old ones? Can 6 be done on one this old?

Picture of the pcb on google drive: ... 7poCGPWS7D

Re: Roms not loading, cant find newly added roms

Posted: Wed Feb 05, 2020 11:18 pm
by dee2eR ... 2wbN1c41vd

there's 8 pads needing to be turned into 4 linked sets, near the top & near the JAMMA edge in the photo. I've highlighted where to join in redish colour. It is probably possible to do with only solder but you may want to use a little wire rather than trying to bridge across the pads with just solder.

Your board hasn't got any other solder there already so no need to worry about cleaning up first.