Black Screen/Not booting after trying to update with newer version

Installing ARpiCADE for the first time? Having issues? Check here first for solutions and tips on installing.

Moderator: dee2eR

Post Reply
vhstape
Community Member
Community Member
Posts: 13
Joined: Sun Mar 04, 2018 3:06 am

Black Screen/Not booting after trying to update with newer version

Post by vhstape » Wed May 12, 2021 3:38 am

Hello Everyone!

So I've had the the ARpiCADE running on my 19 inch original CRT monitor arcade cabinet for the past 3 years with no problems. I decided to update from the version that came on the card. (I bought the full raspberry pi w/ roms on mini sd card and it have had it working fine) After flashing the card with Etcher adding the version 3.X, then partitioning, and adding roms.

I added the card back to my pi and when I turn on the cabinet the screen is on, and the raspberry pi is receiving power with a solid red LED, but its completely black. No boot up, load screen or anything. I even went out and bought a new micro sd card in the case that I corrupted the other one and still having the same problem. I've tried many different settings in the config file, and it didn't work, I also tried different versions of ARpiCADE (4.2, 3.83) to see if any others would work, and am running into the same problems. I can't figure it out! Any ideas? Thanks for your help in advance.

dee2eR
Inventor
Inventor
Posts: 1517
Joined: Tue Aug 22, 2017 2:07 pm

Re: Black Screen/Not booting after trying to update with newer version

Post by dee2eR » Wed May 12, 2021 3:50 am

What model Pi do you have? ARpiCADE 4.[whatever] is the Pi4 branch. 3.X.1 is the current version for Pi3 or Pi2

Best advice I can think of would be to try burning to the SD card again but don't resize any partitions. Just try the image as is before you adjust the partitions, this way we will find out if something is going wrong with the partition adjustment stage. I feel like it's the most likely case, solid red LED without any activity on the green suggests it's not booting at all. The defrault settings are for low res so it should be safe to try the image as released with no edits to config files too.

If the image as released doesn't work you have either wrong model Pi for the software, SD card burning issues or the image I released has gone bad in some way (but I don't think that will be it as you have tried multiple images).

Whatever it is I'm confident we can figure it out.

vhstape
Community Member
Community Member
Posts: 13
Joined: Sun Mar 04, 2018 3:06 am

Re: Black Screen/Not booting after trying to update with newer version

Post by vhstape » Wed May 12, 2021 4:07 am

Thank you for the fast reply! I have a Raspberry pi 3 v 1.2 . I am reflashing the card now. Will let you know what happens once I test.

vhstape
Community Member
Community Member
Posts: 13
Joined: Sun Mar 04, 2018 3:06 am

Re: Black Screen/Not booting after trying to update with newer version

Post by vhstape » Wed May 12, 2021 4:10 am

OMG It Works!!!! Ok, so is it something with partitioning the drive?

dee2eR
Inventor
Inventor
Posts: 1517
Joined: Tue Aug 22, 2017 2:07 pm

Re: Black Screen/Not booting after trying to update with newer version

Post by dee2eR » Wed May 12, 2021 5:09 am

Sounds like it. Were you following the FrizzleFried guide to resizing? It's the best guide I know of (it's not actually how I do it but I use Linux...).

Not sure if it's applicable in this case but I had someone send me a knock off SanDisk SD card recently that would mess up when I resized it but worked fine if I left it at the stock image size. My conclusion at the time was the knock off card was either much smaller than it claimed to be or had some other issue due to being counterfeit. In that particular case the SD card was coloured all wrong and an obvious fake.

As you previously had the SD card working it may not be the SD card at fault, but something is definately going wrong when you move/resize the partitions.

vhstape
Community Member
Community Member
Posts: 13
Joined: Sun Mar 04, 2018 3:06 am

Re: Black Screen/Not booting after trying to update with newer version

Post by vhstape » Fri May 14, 2021 9:41 pm

Yah I tried to follow his tutorial the best I could, but I am using a mac, so I can't use the exact programs that he is using. One thing I could try, is deleting everything off the card once I re-partition the sd card, and then just copy/paste the 3.x folders back onto the SD card and then add roms?

dee2eR
Inventor
Inventor
Posts: 1517
Joined: Tue Aug 22, 2017 2:07 pm

Re: Black Screen/Not booting after trying to update with newer version

Post by dee2eR » Sun May 16, 2021 6:20 am

That won't work. The second partition contains a Linux system, trying to copy it around as files would break it. You can copy/paste the contents of the first partition though.

You should be able to get GParted on Mac, which should be able to do the partition work you need. It's what I use on Linux.

Post Reply