Issue when returning to Attract-Mode

Questions and tweaks for Attract-Mode on ARpiCADE.

Moderator: dee2eR

Post Reply
ShaneHero
Community Member
Community Member
Posts: 17
Joined: Mon Mar 04, 2019 12:38 pm

Issue when returning to Attract-Mode

Post by ShaneHero » Mon Mar 04, 2019 8:54 pm

I’m having a consistent issue where Attract-Mode is going all skewed and squashed to the left of the screen when I exit out of a game.

It always loads perfect when I turn on the machine. But once I exit out of the first game, it’s skewed and squashed. But it still works fine. But remains like this when I exit any games, until I restart it again.

Functionally it’s working. But I want to actually enjoy the nice looking attract mode obviously!

Thanks in advance for the help!

dee2eR
Inventor
Inventor
Posts: 909
Joined: Tue Aug 22, 2017 2:07 pm

Re: Issue when returning to Attract-Mode

Post by dee2eR » Mon Mar 04, 2019 10:46 pm

I haven't seen that behavior before. What sort of monitor are you running? Have you made any changes to the software?

It sounds like it maybe something to do with the resolution changing from 480i to 240p and back again, it may be worth trying one of the 240p only modes if you cannot figure out why it is happening.

ShaneHero
Community Member
Community Member
Posts: 17
Joined: Mon Mar 04, 2019 12:38 pm

Re: Issue when returning to Attract-Mode

Post by ShaneHero » Mon Mar 04, 2019 11:14 pm

Thanks. I’ll give that a shot and see if it helps!

ShaneHero
Community Member
Community Member
Posts: 17
Joined: Mon Mar 04, 2019 12:38 pm

Re: Issue when returning to Attract-Mode

Post by ShaneHero » Wed Mar 06, 2019 7:13 am

I’ve tried different resolutions and still having the same issue.

I’m running an old arcade monitor. Everything else is looking perfect, and no other graphics issues. All the emulators continue to run perfectly fine, even when attract mode is doing this.

Haven’t made any changes to the software, other than doing a flip of the monitor. However, when changing the resolution, I’ve played around with the image still upside down, and it has the same issue still occurring then as well.

ShaneHero
Community Member
Community Member
Posts: 17
Joined: Mon Mar 04, 2019 12:38 pm

Re: Issue when returning to Attract-Mode

Post by ShaneHero » Wed Mar 06, 2019 7:17 am

Here’s how it starts
405DCBA8-1C3F-4E1E-B8EF-DF7144B362A9.jpeg
405DCBA8-1C3F-4E1E-B8EF-DF7144B362A9.jpeg (40.53 KiB) Viewed 950 times
Here’s how it ends up after exiting a game, and remains this way until restarting.
F78B0BE9-6457-4E6E-87B0-A919A0538EA7.jpeg
F78B0BE9-6457-4E6E-87B0-A919A0538EA7.jpeg (37.99 KiB) Viewed 950 times

dee2eR
Inventor
Inventor
Posts: 909
Joined: Tue Aug 22, 2017 2:07 pm

Re: Issue when returning to Attract-Mode

Post by dee2eR » Sat Mar 09, 2019 12:09 am

That is odd. This happens even on the progressive scan only (240p) mode? Does it happen no matter what game you run or only after the resolution has actually changed? (in progressive only mode some games won't need to change the resolution at all so I would imagine that this couldn't happen)

Always confusing when someone has something or behavior I cannot replicate happening. Hopefully we can get to the bottom of it.

ShaneHero
Community Member
Community Member
Posts: 17
Joined: Mon Mar 04, 2019 12:38 pm

Re: Issue when returning to Attract-Mode

Post by ShaneHero » Sat Mar 09, 2019 12:54 am

Yeah, I've tried the different resolutions and it still happens. It happens with all of the games as well. But I have had one or two occasions where it hasn't happened, which has got my hopes up. Only for it to then continue to happen.

Granted, I don't have a lot of knowledge or experience with this yet, but I haven't been able to establish any sort of pattern or reason for it to be happening either. As far as I can tell it's happening with all games, all the time, but will randomly not do it on occasion.

dee2eR
Inventor
Inventor
Posts: 909
Joined: Tue Aug 22, 2017 2:07 pm

Re: Issue when returning to Attract-Mode

Post by dee2eR » Sat Mar 09, 2019 4:30 am

How are you changing resolution and which version of ARpiCADE are you using?

User avatar
FrizzleFried
Legendary Contributor
Legendary Contributor
Posts: 277
Joined: Sat Nov 25, 2017 5:35 pm
Location: Idaho
Contact:

Re: Issue when returning to Attract-Mode

Post by FrizzleFried » Sat Mar 09, 2019 5:27 pm

Hard set the resolution you want in the layout.nut file?

Add this to the layout.nut file... of course look for similar lines to modify first...

fe.layout.width=640;
fe.layout.height=480;

Of course use the width/height you want.
Visit my arcade blog ... www.idahogaragecade.com (Updated: 06/27/19)

ShaneHero
Community Member
Community Member
Posts: 17
Joined: Mon Mar 04, 2019 12:38 pm

Re: Issue when returning to Attract-Mode

Post by ShaneHero » Mon Mar 11, 2019 9:45 pm

I spent the weekend playing around with he settings and this time around the 240 resolution seems to have permanently solved the issue now.

Thanks again everyone for your expertise! It is running perfectly now.

Post Reply