Pi4 No sound intermittently & sound pops

Questions and tweaks for Attract-Mode on ARpiCADE.

Moderator: dee2eR

Post Reply
discosheep
Community Member
Community Member
Posts: 5
Joined: Tue Feb 01, 2022 8:46 pm

Pi4 No sound intermittently & sound pops

Post by discosheep » Sun Feb 13, 2022 4:25 am

Hey Hey, I have ARpiCADE 4.3.1 and having sound issues in Attract mode and Mame with my 1 Player horizontal setup on a pi4.

No sound in games & attract mode (SDarcadeMod v2)intermittently and also sound popping in a lot of games like Ghosts N Goblins.
I've tried in different Mame versions but seems to not having great luck.

When I cycle through the games in attract mode, the scroll noise doesn't happen the first time I move the joystick and then if I start a game there is no sound at all. If I return to the menu then move around the menu a bit & come back to the same game the sound is working. I noticed that there is some volume tapering when sounds begin so I'm wondering if this is why & how to change the sound settings to fix this.

The popping in Mame games can be fixed by changing the refresh rate slider but this setting doesn't want to save.

Any help would be appreciated.
cheers!

dee2eR
Inventor
Inventor
Posts: 1875
Joined: Tue Aug 22, 2017 2:07 pm

Re: Pi4 No sound intermittently & sound pops

Post by dee2eR » Tue Feb 15, 2022 1:56 am

could possibly be related to the 3.5mm audio cable, although I'm far from sure... it's worth checking the connections and perhaps unplugging and replugging in case it's just not making a good connection.

Sound popping in game can be caused if the game is not quite at the perfect original refresh rate, I'd have to check the games to confirm though - I would have though Ghosts and Goblins would be right (as most Capcom is). What res are you running the system at?

I think this is 2 different audio issues... not sure why for now but we can probably figure it out.

discosheep
Community Member
Community Member
Posts: 5
Joined: Tue Feb 01, 2022 8:46 pm

Re: Pi4 No sound intermittently & sound pops

Post by discosheep » Tue Feb 15, 2022 9:30 am

I figured out what's happened regarding the sound pops & it's my fault! I swapped in the low res horizontal config file for MAME172 and that's sorted all the games with those issues.

I checked the audio cable at both ends. I'm still getting the odd game starting with no sound.. which I can resolve by exiting back to the menu then trying again.

dee2eR
Inventor
Inventor
Posts: 1875
Joined: Tue Aug 22, 2017 2:07 pm

Re: Pi4 No sound intermittently & sound pops

Post by dee2eR » Wed Feb 16, 2022 1:51 am

sounds like a software issue if reloading a game fixes it. That said, I'm not sure why - is it only one emulator doing it?

discosheep
Community Member
Community Member
Posts: 5
Joined: Tue Feb 01, 2022 8:46 pm

Re: Pi4 No sound intermittently & sound pops

Post by discosheep » Thu Feb 17, 2022 6:21 am

cheers! I will check to see if it's one emulator however I do notice that the attract mode 'scroll' noise sometimes does not sound and sometimes not at all until I play a game and return to the menu.

discosheep
Community Member
Community Member
Posts: 5
Joined: Tue Feb 01, 2022 8:46 pm

Re: Pi4 No sound intermittently & sound pops

Post by discosheep » Fri Feb 25, 2022 4:53 am

Hi, I've just been playing on my Coin Cascade upright cabinet and loving it! Sound pops are all sorted now but still getting games intermittently starting from Attract mode with no sound for different versions of mame. Not sure where the sound config files are that I can play with.

Post Reply