Completely lost.

Thinking about getting a RaspberryJAMMA, or have just purchased one and have a newbie question? Walls here are padded, come on in and bounce your question off of them!

Moderator: dee2eR

dee2eR
Inventor
Inventor
Posts: 910
Joined: Tue Aug 22, 2017 2:07 pm

Re: Completely lost.

Post by dee2eR » Sat Jul 13, 2019 5:03 am

No use disk imaging software to make an image (perfect copy) of the SD card. I don't really use Windows to know what to suggest but I hear Win32DiskImager get brought up often.

No idea how good it is but this tutorial may help: https://thepihut.com/blogs/raspberry-pi ... is-sd-card

mac48045
Community Member
Community Member
Posts: 11
Joined: Fri Jul 12, 2019 5:05 pm

Re: Completely lost.

Post by mac48045 » Sat Jul 13, 2019 6:13 pm

Picture is perfect now. Next question, how do I get non working preinstaled ROMs to work. Specifically Pacman and X-Men, both show on game select but when selected the do not run just kick me back to select screen.

buverman
Community Member
Community Member
Posts: 11
Joined: Tue Mar 06, 2018 7:57 am

Re: Completely lost.

Post by buverman » Sat Jul 13, 2019 10:00 pm

There is a very good change you are not using the correct roms. Has happened to me many times when I used merged romsets. Make sure your roms match the correct MAME version folder as well.

dee2eR
Inventor
Inventor
Posts: 910
Joined: Tue Aug 22, 2017 2:07 pm

Re: Completely lost.

Post by dee2eR » Sun Jul 14, 2019 1:30 am

Pacman and Xmen should work fine on ARpiCADE. Maybe try a different copy of the roms or try a different emulator, not sure how your card is setup so I don't have a specific answer for your build.

mac48045
Community Member
Community Member
Posts: 11
Joined: Fri Jul 12, 2019 5:05 pm

Re: Completely lost.

Post by mac48045 » Sun Jul 14, 2019 10:50 pm

I have tried every included mame emulator and I can't get Simpsons, X-Men, or ninja turtles to work. They all show on game selection screen just won't run. Any ideas?

mac48045
Community Member
Community Member
Posts: 11
Joined: Fri Jul 12, 2019 5:05 pm

Re: Completely lost.

Post by mac48045 » Sun Jul 14, 2019 10:53 pm

All 3 are early 90s Konami games

dee2eR
Inventor
Inventor
Posts: 910
Joined: Tue Aug 22, 2017 2:07 pm

Re: Completely lost.

Post by dee2eR » Sun Jul 14, 2019 11:17 pm

All those games should be able to work. Not sure why they wouldn't be on your build. Either you're missing a file needed by the games or your roms are bad or something.

In the case of Pacman you will need to also have the Puckman rom as it is the parent. For the Konami games you mentioned there's 4 player, 2 player and some other variations - you'll need the four player roms at a minimum as they're the parent roms, often the 2 player roms are used for character selection on a 2 player machine. If you have the 2 player roms in the game list and not the 4 player parents they may be hidden by rom scanner rather than missing so it's worth checking the rom folders for the missing files rather than relying on the gamelist (the same is true of Puckman - it may be there and just hidden from the list...)

Unfortunately I don't have your build in front of me to be able to figure out the issue for you. I don't know what has or hasn't been done to the software already. I'm not even sure which ARpiCADE version you have, is there any version info in /boot/USER_GUIDE/ ?

Post Reply