640x480 best way to setup?

Installing ARpiCADE for the first time? Having issues? Check here first for solutions and tips on installing.

Moderator: dee2eR

Post Reply
raycade
Community Member
Community Member
Posts: 5
Joined: Thu Feb 13, 2020 11:14 am

640x480 best way to setup?

Post by raycade » Sun Mar 08, 2020 10:54 am

Hi,

I'm very happy with the ARpiCADE running on a 15KHz lowres + interlaced mode.

I'm now thinking about using the ARpiCADE board also in a VGA only CRT monitor setup, which is inside my other Atomisewave cabinet, meaning it requires a 640x480 VGA 31KHz output.
This means that the menu must be 640x480 but also all the games are at least using this same 640x480 resolution.

What is the best configuration for this?
And what do I have to set in order to get this? (example config please, also pointing out which file or menu I have to do this).

Cheers...

dee2eR
Inventor
Inventor
Posts: 981
Joined: Tue Aug 22, 2017 2:07 pm

Re: 640x480 best way to setup?

Post by dee2eR » Mon Mar 09, 2020 8:08 am

640x480 should be what you want for VGA screens. There's no pre-done settings for any higher res. To change to VGA mode:
Make a backup image of your SD card before making changes if you haven't already done so, just in case. Use Notepad++ for editing if you're on Windows.

Start by setting the Pi to the resolution you want in
/boot/config.txt
using the
hdmi_mode=
setting you desire. This will ensure the hardware boots at the resolution you want and is the first thing to do. Uncomment the 480p option and don't forget to comment out the lowres one.

You will then need to edit the service menu launcher script (boot/launchers/servMenu.sh) to uncomment (remove the ‘#’ hash) the highres options. After doing this the option available in the service menu will work and will reconfigure the system when selected. When the relevant option is selected the system will reconfigure itself and reboot in the selected settings.

When you power up do not launch any games as they will change the res... just press 'service' or 'f4' to exit the game menu to the service menu, select the highres option you want (horizontal or vertical). It should reboot and now you can launch games without it changing to 240p.

Post Reply