Player 1 Joystick - no Up in AdvanceMame

Installing ARpiCADE for the first time? Having issues? Check here first for solutions and tips on installing.

Moderator: dee2eR

Post Reply
Marty
Community Member
Community Member
Posts: 3
Joined: Wed May 20, 2020 3:48 am

Player 1 Joystick - no Up in AdvanceMame

Post by Marty » Wed May 20, 2020 3:57 am

Hi all, Newbie here.

Got my Arpicade set up installed and was working well then i tried some games that require upward movement and the player 1 joystick has no up movement. Player 2 joystick works fine.
Thought maybe faulty microswitch in Joystick 1 - checked with multimeter and tests ok.

Also tried Keyboard control via USB and same issue with up key not working in games.

Bit of Linux novice so not really keen on hacking around files without clear guidance but had a look and saw consistent settings in files around Joystick raw etc for P1 and P2.

If it was Joystick HW why does the Keyboard have the same issue via USB(bypassing the joystick wiring)?

EDIT - up key /Joystick works in UP direction on other emulators and menus but not in advmame games

Any suggestions of what it could be? Appreciate any thoughts or direction here.

Cheers,

Marty

Marty
Community Member
Community Member
Posts: 3
Joined: Wed May 20, 2020 3:48 am

Re: Player 1 Joystick - no Up in AdvanceMame

Post by Marty » Wed May 20, 2020 5:47 am

Well, thats really weird.
Went into the advmame emulator controls via the gui and reentered exactly the same settings that were there.
Seems to have come good.
My only guess is i had a corrupt settings file that was re written when i reentered the same settings.

dee2eR
Inventor
Inventor
Posts: 1151
Joined: Tue Aug 22, 2017 2:07 pm

Re: Player 1 Joystick - no Up in AdvanceMame

Post by dee2eR » Thu May 21, 2020 1:28 am

That's odd but I'm glad you found a solution. Especially odd you had issue with keyboard and joystick up... at least it works right now.

Marty
Community Member
Community Member
Posts: 3
Joined: Wed May 20, 2020 3:48 am

Re: Player 1 Joystick - no Up in AdvanceMame

Post by Marty » Thu May 21, 2020 3:43 am

seems to only work as a 4 way despite being set as an 8 way. But will do for now.

Post Reply